Degraded performance of some APIs in Production

Incident Report for VA APIs

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 09:16 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2025 - 16:40 EDT

Investigating

VA API dependencies are experiencing disruptions due to an unexpected event. As a result, the Veteran Service History and Eligibility - v2 and VA Letter Generator APIs in Production are experiencing increased latency at this time.

We’re working on this issue and will give updates as soon as they become available.
Posted Jun 24, 2025 - 15:02 EDT
This incident affected: Veteran Service History and Eligibility API - v2 (Production Environment) and VA Letter Generator API (Production Environment).